Skip to content

[BUG] Startup issues with v5 - report here #685

Description

@el-tiuri

v5 fails to start up using the recommended docker-compose file.

Logs:
2026-03-03T10:18:24Z INF cmd/tinyauth/tinyauth.go:114 > Starting tinyauth log_stream=app version=v5.0.0
2026-03-03T10:18:24Z fatal Failed to execute command | error=command tinyauth error: failed to bootstrap app: parse "://": missing protocol scheme

Activity

  1. changed the title [-][BUG][/-] [+][BUG] v5 fails to start up[/+] on Mar 3, 2026
  2. kusk commented on Mar 3, 2026

    @kusk

    Same error here.

  3. steveiliop56 commented on Mar 3, 2026

    @steveiliop56
    Member

    Can you share the docker compose file you used? Is it the one from the documentation or did you customize it?

  4. kusk commented on Mar 3, 2026

    @kusk
    networks:
      caddy_network:
        name: caddy_network
        external: true
    
    services:
      tinyauth:
        container_name: tinyauth
        image: ghcr.io/steveiliop56/tinyauth:latest
        restart: unless-stopped
        volumes:
          - /data/tinyauth:/data
          - /var/run/docker.sock:/var/run/docker.sock
        environment:
          - TINYAUTH_OAUTH_PROVIDERS_GOOGLE_CLIENTID=...
          - TINYAUTH_OAUTH_PROVIDERS_GOOGLE_CLIENTSECRET=...
          - TINYAUTH_OAUTH_WHITELIST=….
          - TINYAUTH_APP_URL=http://tinyauth.....com
        labels:
          caddy: http://tinyauth.....com
          caddy.reverse_proxy: "{{upstreams 3000}}"
          tinyauth.apps.tinyauth.config.domain: tinyauth…..com
        networks:
          - caddy_network
    

    I have tried to migrate to the new config, but not sure I did it correctly.

  5. kusk commented on Mar 3, 2026

    @kusk

    I found the error myself. I had to change from TINYAUTH_APP_URL to TINYAUTH_APPURL without the last underscore.

  6. steveiliop56 commented on Mar 3, 2026

    @steveiliop56
    Member

    @kusk and @el-tiuri there seems to be an misunderstanding as to the migration instructions. The migration does not only involve adding the TINYAUTH_ prefix but also changing and categorizing most of the configuration options. For your static configuration options (so everything but the OAuth providers) you can use the automated configuration migrator (everything happens browser side). As for the OAuth configuration, please refer to the documentation for all of the new options you should use.

  7. kusk commented on Mar 3, 2026

    @kusk

    Yeah, I ended up using both the migator and the documentation to fix the problem.

  8. TonyCollett commented on Mar 3, 2026

    @TonyCollett

    The Migrator doesn't seem to pick up values correctly.

    Image

    On the left is my original working configuration (blurred of course) and on the right is what was automatically migrated. I'm still having an issue with starting TinyAuth

    EDIT: Worked out my issue with the configuration values (CLIENT_ID needed to be CLIENTID, and so on) and got it running. Might want to include a full list of changes (i.e. PROVIDERS_[NAME]_CLIENT_ID is now TINYAUTH_OAUTH_PROVIDERS_[NAME]_CLIENTID)

  9. steveiliop56 commented on Mar 3, 2026

    @steveiliop56
    Member

    Yes there is a warning about dynamic values below. They are not supported by the migrator, you will have to migrate them manually.

  10. TonyCollett commented on Mar 3, 2026

    @TonyCollett

    Yes there is a warning about dynamic values below. They are not supported by the migrator, you will have to migrate them manually.

    Ahh, I didn't realise that. All good then. Thanks for the update

  11. sebinistor commented on Mar 4, 2026

    @sebinistor

    Same issue in the UNRAID community edition when pulling with tag :latest
    I reverted to 4.1.0 as it is not clear which variable of the container needs an updated and to what...

  12. YouveGotMeowxy commented on Mar 4, 2026

    @YouveGotMeowxy

    I'm getting a similar error:

    Image

    my .env file:

    TZ="America/Chicago"
    
    TINYAUTH_APPURL="https://tinyauth.domain.com"
    TINYAUTH_DATABASEPATH="/data/tinyauth.db"
    TINYAUTH_RESOURCESDIR="/data/resources"
    TINYAUTH_LOGJSON="true"
    TINYAUTH_LOGLEVEL="trace"
    TINYAUTH_SERVER_PORT="3000"
    TINYAUTH_AUTH_USERSFILE="/data/users"
    TINYAUTH_AUTH_SECURECOOKIE="true"
    TINYAUTH_UI_TITLE="GATE"
    TINYAUTH_UI_FORGOTPASSWORDMESSAGE="Contact admin to reset your password"
    
  13. steveiliop56 commented on Mar 4, 2026

    @steveiliop56
    Member

    @YouveGotMeowxy seems like the environment variables are not passed to Tinyauth. But, even if they are passed configuration will most likely fail to parse due to the following options:

    TINYAUTH_DATABASEPATH="/data/tinyauth.db"
    TINYAUTH_RESOURCESDIR="/data/resources"
    TINYAUTH_LOGJSON="true"
    TINYAUTH_LOGLEVEL="trace"

    They should be:

    TINYAUTH_DATABASE_PATH="/data/tinyauth.db"
    TINYAUTH_RESOURCES_PATH="/data/resources"
    TINYAUTH_LOG_JSON="true"
    TINYAUTH_LOG_LEVEL="trace"

    @sebinistor basically the entire configuration changed. The environment variables and CLI flags now follow a new scheme. You can visit the reference, find the new environment variable that fits your use case and migrate it. Alternatively, you can use the config migrator (as mentioned won't work for OAuth variables, you will have to manually migrate those).

  14. 15 remaining items

  15. andreasntr commented on Apr 12, 2026

    @andreasntr

    Is TINYAUTH_AUTH_USERSFILE dealing with the file in a different way than v4? My file has not changed and i get the following error:

    2026-04-12T15:58:07Z INF cmd/tinyauth/tinyauth.go:115 > Starting tinyauth log_stream=app version=v5.0.6
    
    2026-04-12T15:58:07Z fatal Failed to execute command | error=command tinyauth error: failed to bootstrap app: invalid user format
    

    I noticed i have a ":" char in one of the hashed passwords but the format is correct (user:password_with_:_in_the_middle,user:password)

  16. steveiliop56 commented on Apr 12, 2026

    @steveiliop56
    Member

    Users in the file should be one per line not separated by a comma (although the parser should be able to load it). Apart from this, your bcrypt hash is just invalid. Bcrypt hashes don't use colons. Try to regenerate your user using the CLI.

  17. andreasntr commented on Apr 12, 2026

    @andreasntr

    Users in the file should be one per line not separated by a comma (although the parser should be able to load it). Apart from this, your bcrypt hash is just invalid. Bcrypt hashes don't use colons. Try to regenerate your user using the CLI.

    That's weird, v4 doesn't complain and detects both users.

    Anyway, if this is the intended way, please also update the docs since TINYAUTH_AUTH_USERS talks about "Comma-separated list of users" but TINYAUTH_AUTH_USERSFILE does not mention it has to be a multi-line file.

    Thanks for taking the time to answer, awesome work 🫡

    EDIT: The ":" sign was due to the presence of TOTP authentication (user:password:totp)

  18. bsaurusrex commented on Oct 9, 2026

    @bsaurusrex

    Opened four small PRs that address issues reported in this thread:

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

bugSomething isn't workingpinnedThis issue is pinned

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions